TOP

The Projects Pane

Applies to: NAS-1Step LTE/EPC r15.8.0 v7.2.1

Description

When NAS-1Step starts, it displays an empty projects pane. By default, the projects pane is on the left side of the frame window. The rest of the main application window is empty. You can then open or create a project by using the File menu commands or toolbar icons.

When you create or open a project, the contents of the project are displayed in a tree-like view in the projects pane. When you open multiple projects, the contents of all of them will be displayed in the projects pane, each project being a separate root of the tree-like view.

Each project contains references to four types of files, gathered into the following groups:

  • ASN.1 Files
  • Encodings -- UE-Originating
  • Encodings -- Network-Originating
  • User Files

The ASN.1 Files group contains a complete ASN.1 schema for NAS messages. NAS-1Step translates the definitions in the ASN.1 schema into an internal description. This internal description is subsequently used to decode and encode NAS messages as they are displayed and edited in the message viewer/editor.

The Encoded Messages (UE-Originating) file group contains a set of files, each containing the bytes of a single NAS encoded message. The messages in this file group are treated as originating in the UE rather than in the network. This distinction is important in the NAS protocol because certain types of messages are only allowed to be sent by one type of endpoint (originator), and the interpretation of the encoded data in certain messages may change based on the originator.

Project file groups

The main purpose of including a file in this group is to enable the NAS-1Step application to decode and display the contents of the file interpreted as a NAS encoded message produced by a UE. In NAS-1Step, the fact that a file belongs to a certain file group provides the application with additional information it needs to decode and display the file, namely, whether the file in question contains a UE-originating message or a network-originating message.

The Encoded Messages (Network-Originating) file group contains a set of files, each containing the bytes of a single NAS encoded message. The messages in this file group are treated as originating in the network. Analogous considerations to those made above for the Encoded Messages (UE-Originating) file group apply to this file group.

The User Files group contains a set of files that are of interest to the user for any reason. In the present version of NAS-1Step, no particular function is associated with these files.

There is no application-defined limit to the number of files that can be included in each group. Each file may reside anywhere in the file system, but the files in each group are always displayed as a flat list in the projects pane.

There are three menu items that control the display of the contents of a project in the projects pane. All of them apply to an individual project, and so when you open multiple projects, each of them can have different settings.

Show Relative Paths

The Show Relative Paths checkable menu option controls the display of the file names that belong to the project. When this option is not active (default), the application shows the filename and the extension of each file. When this option is active, the application shows the relative path, the filename, and the extension. The relative path of each file is either relative to the directory containing the project file or relative to the directory specified in the project view filter (see below), depending on whether the project view filter is currently active. This option applies to all the file groups of the selected project, and only affects the way the contents of each file group are displayed in the projects pane, not the contents of the project in memory or in the project file. The "[R]" suffix is appended to the filename of the project as shown in the project pane when this option is active.

Sort Alphabetically

The Sort Alphabetically checkable menu option controls the order in which the members of each file group are listed. When this option is not active (default), the files in each group are listed in the order in which they occur inside the project (both in memory and in the project file). You can change this order permanently by issuing the Move Up and Move Down commands on individual files. When this option is active, the files in each group are listed in alphabetical order. The sort is performed on the names as displayed in the projects pane. Therefore, if the Show Relative Paths option is active, the members are sorted by relative path, filename, and extension, otherwise they are sorted by filename and extension. This option applies to all the groups of the selected project, and only affects the way the contents of each group are displayed, not the contents of the project in memory or in the project file. The "[A]" suffix is appended to the filename of the project as shown in the project pane when this option is active.

The Set Project View Filter menu command controls a feature called the project view filter. The project view filter of a project consists of a directory and a subtree flag, and it can be either active or inactive. When the project view filter is active and the subtree flag is set to false, only those members of the project that reside in the specified directory are listed in the projects pane. When the project view filter is active and the subtree flag is set to true, only those members of the project that reside either in the specified directory or in any descendants of that directory (at any depth) are shown.

Set Project View Filter

When you deactivate the project view filter, the application remembers the directory of the filter and the subtree flag, so you won't need to re-specify these attributes when you activate the filter again. This option applies to all the groups of the selected project, and only affects the way the contents of each file group are displayed, not the contents of the project in memory or in the project file. The project view filter can be useful when a project contains a large number of files organized into several directories or subtrees and you want to deal with one of them at a time. The "[F]" suffix is appended to the filename of the project as shown in the project pane when this option is active.

The

The options described above are separately specified for each open project, and affect the display of all the members of all the file groups of the project.

Menu commands and options

Main menu items affecting the projects pane

Menu item Shortcut key Description
File / New Project Ctrl+N1 Creates an empty project with no title and opens it in the projects pane.
File / Open Project... Ctrl+O1 Displays an Open dialog box that allows the user to select a project file to be opened, and then opens the project selected by the user.
File / Close All   Closes all the open files. If there are any open files that have been modified since the last time they were opened or saved, the application saves each of them after asking for and receiving permission from the user. This also applies to project files (see Save Project below).
File / Save All   Saves all the open files that have been modified since the last time they were opened or saved. This also applies to project files (see Save Project below).
File / <recently used file>   Opens the indicated project file. A project file name is added to the File menu when it is opened or saved.
File / Exit   Terminates the application.
If there are any open files that have been modified since the last time they were opened or saved, the application saves each of them after asking for and receiving permission from the user. This also applies to project files (see Save Project below).
View / Toolbars and Docking Windows / Projects   This is a checkable menu option that determines whether the projects pane is displayed or hidden. Note that this affects only the display status of the projects pane. If there are any open projects, those projects remain open when the pane is hidden.

Context menu: project heading

Menu item Shortcut key Description
Close Project   Closes all the open files (e.g., encoded messages) that belong to the selected project and then closes the project file. If there are any open files (including the project file) that have been modified since the last time they were opened or saved, the application saves each of them after asking for and receiving permission from the user.
Save Project Ctrl+S2 Saves the selected project file. If any members have been added to the project or removed from the project, or if the order of the members in a file group has been changed by moving some members up or down, this is the time when those changes become permanent. If you do not save the project file, those changes will be lost. No other files are saved.
Save Project As...   Displays a Save As dialog box that allows the user to rename the selected project file and save it under a new name. No other files are saved.
Show Relative Paths Ctrl+R2 This is a checkable menu option. When this option is not active, only the file name and extension of each file is shown. When this option is active, each name is prefixed by a relative path (possibly empty). Each relative path is either relative to the directory containing the project file or relative to the directory specified in the project view filter, depending on whether the project view filter is currently off or on, respectively (see Set Project View Filter below).
Sort Alphabetically Ctrl+A2 This is a checkable menu option. When this option is not active, the members of each group are displayed in the order in which they occur inside the project in memory. When this option is active, the members of each group are displayed in alphabetical order. The sort operates on the names displayed in the projects pane, and therefore, if the Show Relative Paths option is also active, the members of each group will be sorted first by relative path and then by filename.
Set Project View Filter... Ctrl+F2 Opens a dialog box that allows the user to set the project view filter of the selected project. The project view filter consists of a directory and a subtree flag, and it can be either on or off. When the project view filter is turned on for a project and the subtree flag is off, only those members of the project that reside in the specified directory are shown. When the project view filter is on and the flag is on, only those members of the project that reside either in the specified directory or in any descendants of that directory (at any depth) are shown.
Settings...   This command has no effect in the present version of NAS-1Step.

Context menu: file group heading

Menu item Shortcut key Description
New... Ctrl+N2 Creates an empty file and adds it to the selected group. The only type of file that can be created and edited in the present version of NAS-1Step is an encoded message file. Therefore, this command is enabled only for the Encoded message (UE-originating) and Encoded message (network-originating) groups. After the new file has been added to the group, you have to open it explicitly with the Edit context menu command (or by pressing Enter, or by double-clicking on the filename) when you want to edit it.
Add File... Ctrl+O2 Displays a dialog box that allows the user to select one or more existing files (anywhere in the file system) and add them to the selected group. It is the user's responsibility to ensure that the correct types of files are being added to each group. When you add to an Encoded message group a file that is not a NAS encoded message and then try to edit it, the built-in NAS encoder/decoder will try to decode it. If a decoding error occurs (which is probable but not certain), the file will be treated as an invalid NAS encoding rather than as something other than a NAS encoding.
Paste Ctrl+V2 Adds one or more file references from the Windows system clipboard into the selected file group. The file references must already be placed in the clipboard either by using the Copy operation (see Copy below) on a member of another file group of either the same or a different project, or by using the standard Copy operation in Windows Explorer or any other application that can copy file references to the Windows system clipboard.

Context menu: individual file

Menu item Shortcut key Description
View Enter2 Opens the selected file for display (not for editing) into a viewer of the appropriate type, such as the ASN.1 schema file viewer.
Edit Enter2 Opens the selected file for display and editing into a viewer/editor of the appropriate type, such as the message viewer/editor that supports the display and editing of a NAS message.
Edit as Hex   Opens the selected file for display and editing into a hexadecimal viewer/editor.
Open With...   Displays a dialog box that allows the user to choose an external application for opening the selected file for display (and possibly editing), and then launches the chosen application with the selected file.
Cut Ctrl+X2 Copies a reference to the selected file into the Windows system clipboard and removes it from the project in the same way as the Remove command (see Remove below) does. You will then be able to paste the file into a different group of either the same or another project in NAS-1Step. You will also be able to paste the file into a different application such as Windows Explorer. Note that only a reference to the file, not its entire contents, is copied to the clipboard.
Copy Ctrl+C2 Copies a reference to the selected file to the Windows system clipboard. You will then be able to paste the file into a different group of either the same or another project in NAS-1Step. You will also be able to paste the file into a different application such as Windows Explorer. Note that only a reference to the file, not all its contents, is copied to the clipboard.
Remove Delete2 Removes the selected file from the project. If the file is currently open and has been modified since the last time it was opened or saved, the application saves it after asking for and receiving permission from the user. If the file is currently open, the application closes it.
Move Up Ctrl+Up2 Moves the selected file one position up within its group. The contents of the file are not affected. This command is disabled for the first (or only) file in a group, and also when the Sort Alphabetically option is active.
Move Down Ctrl+Down2 Moves the selected file one position down within its group. The contents of the file are not affected. This command is disabled for the last (or only) file in a group, and also when the Sort Alphabetically option is active.
Properties...   This command has no effect in the present version of NAS-1Step.

1 This shortcut key works when the focus is outside the projects pane.

2 This shortcut key works when the focus is inside the projects pane.


This documentation applies to NAS-1Step for LTE/EPC v7.2.1 for 3GPP Release 15.8.0.

Copyright © 2021 OSS Nokalva, Inc. All rights reserved.
No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means electronic, mechanical, photocopying, recording or otherwise, without the prior permission of OSS Nokalva, Inc.
Every distributed copy of NAS-1Step for LTE/EPC is associated with a specific license and related unique license number. That license determines, among other things, what functions of NAS-1Step for LTE/EPC are available to you.